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Evaluation board/kit and Development tool important notice 

1. This evaluation board/kit or development tool is designed for use for engineering evaluation, demonstration, 

or development purposes only. Do not use it for other purposes. It is not intended to meet the requirements of 

design for finished products. 

2. This evaluation board/kit or development tool is intended for use by an electronics engineer and is not a 

consumer product. The user should use it properly and in a safe manner. Seiko Epson dose not assume any 

responsibility or liability of any kind of damage and/or fire coursed by the use of it. The user should cease to 

use it when any abnormal issue occurs even during proper and safe use. 

3. The part used for this evaluation board/kit or development tool may be changed without any notice. 

 

 

NOTICE 

No part of this material may be reproduced or duplicated in any form or by any means without the written 

permission of Seiko Epson.  Seiko Epson reserves the right to make changes to this material without notice.  

Seiko Epson does not assume any liability of any kind arising out of any inaccuracies contained in this material 

or due to its application or use in any product or circuit and, further, there is no representation that this material is 

applicable to products requiring high level reliability, such as, medical products.  Moreover, no license to any 

intellectual property rights is granted by implication or otherwise, and there is no representation or warranty that 

anything made in accordance with this material will be free from any patent or copyright infringement of a third 

party. When exporting the products or technology described in this material, you should comply with the 

applicable export control laws and regulations and follow the procedures required by such laws and regulations. 

You are requested not to use, to resell, to export and/or to otherwise dispose of the products (and any technical 

information furnished, if any) for the development and/or manufacture of weapon of mass destruction or for other 

military purposes. 

 

Arm, Cortex, Keil and µVision are registered trademarks of Arm Limited (or its subsidiaries) in the US and/or 

elsewhere. IAR Systems, IAR Embedded Workbench, C-SPY, I-jet, IAR and the logotype of IAR Systems are 

trademarks or registered trademarks owned by IAR Systems AB. SEGGER and J-Link are trademarks or 

registered trademarks of SEGGER Microcontroller GmbH & Co. KG. All rights reserved. 

All brands or product names mentioned herein are trademarks and/or registered trademarks of their respective 

companies. 

“Reproduced with permission from Arm Limited. Copyright © Arm Limited” 

©SEIKO EPSON CORPORATION 2021, All rights reserved. 
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1. Overview 

This manual describes how to use the peripheral circuit sample software included in the S1C31xxx peripheral 

circuit sample software package. The peripheral circuit sample software is intended to show how to use the 

peripheral circuit library to control the S1C31xxx peripheral circuits. 

 

In addition to this manual, please also refer to the following. 

⚫ S1C31xxx Technical Manual … Microcontroller details. Available from Seiko Epson website. 

⚫ S5U1C31xxxTx Manual … Evaluation Board details. Available from Seiko Epson website. 

⚫ Manual for debug probe and integrated development environment 

 

1.1  Operating Environment  

Before running the peripheral circuit sample software, prepare the following components: 

• Evaluation Board 

- S5U1C31xxxTx evaluation board equipped with S1C31 Family 

• Debug Probes *1 

- IAR Systems I-jet or SEGGER J-Link 

• Integrated Development Environment 

- IAR Embedded Workbench for ARM® (IAR EWARM) or MDK-ARM® (uVision) 

• S1C31 Setup Tool Package 

- Flash loader and configuration files (.svd, etc.) 

• Other Devices (option) 

*1: I-jet is available only with IAR EWARM. J-Link is available for both IAR EWARM and MDK-ARM. 
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2 Peripheral circuit sample software package configuration 

2.1 Folder configuration 

The configuration of the S1C31xxx peripheral circuit sample software package is as follows. 

 
Figure 2.1.1 Configuration of the S1C31xxx peripheral circuit sample software package 

S1C31xxxSamplePKG_very_yy.zip 

[S1C31xxxSamplePKG_very_yy] 
|- [Licenses] : License group 

|- [Drivers] : Driver group 

|    |- [board] : Drivers related to the evaluation board 
|    |    |- [S5U1C31xxxTx] 

|    |    |    |- [ARM] 

|    |    |    |- [IAR] 
|    |    |    |- board.c/.h : Evaluation board setting program 

|    |    |    |- settings.h : Definition file for setting the function of the evaluation board 

|    |    |    |- … 
|    |- [CMSIS] : CMSIS driver 

|    |    |- [Device] 

|    |    |    |- [S1C31xxx] 
|    |    |        |- [Include] 

|    |    |        |    |-S1C31xxx.h : CMSIS peripheral circuit access layer header file 

|    |    |        |    |- … 
|    |    |        |- [Source] 

|    |    |            |- [ARM] 

|    |    |            |- [IAR] 
|    |    |            |    |- startup_S1C31xxx.s : CMSIS startup program 

|    |    |            |- system_S1C31xxx.c : CMSIS peripheral circuit access layer program 

|    |    |- [Driver] 
|    |    |    |- [Include] 

|    |    |    |    |- Driver_EEPROM.h : CMSIS EEPROM emulation library driver definition 

|    |    |    |    |- Driver_Flash.h : CMSIS self-programming library driver definition 
|    |    |    |    |- … 

|    |    |    |- [Source] 

|    |    |        |- Driver_EEPROM.c 
|    |    |- [SVD] 

|    |- [sePeripheralLibrary] : Peripheral circuit library 

|        |- se_clg.c/.h 
|        |- se_i2c.c/.h 

|        |- … 

|- [Middlewares] : Middleware group 
|    |- [seEepromLibrary] : EEPROM emulation library 

|    |- [seFlashLibrary] : Self-programming library driver definition 

|    |- … 
|- [Projects] : Sample software group 

|    |- [Applications] : Various application software 

|    |    |- [BOOTLOADER] : Sample software for boot loader 
|    |    |- [EEPROM] : Sample software for EEPROM emulation library 

|    |    |- [FLASH] : Sample software for self-programming library 

|    |    |- [IEC60730SELF] : Sample software for self-testing 
|    |    |- … 

|    |- [Demonstration] : Various demonstration software 

|    |- [Examples] : Peripheral circuit sample software 
|        |- [CLG] : Each peripheral circuit function 

|        |    |- [ARM] : Project for MDK-ARM 
|        |    |- [IAR] : Project for IAR EWARM 

|        |    |- main.c 

|        |- [I2C] 
|        |- [PPORT] 

|        |- … 

|        |- [WORKSPACE] : A workspace that collects project of each peripheral circuit function 
|- [Tools] : Tools used by the sample software 

README_e.txt 
README_j.txt 
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2.2 Sample Software configuration 

The sample software (project) included in the S1C31xxx peripheral circuit sample software package uses various 

drivers included in the "Drivers" folder. The software layer of the sample software is shown in Figure 2.2.1. 

 

 

Figure 2.2.1 Software layer of sample software 

 

In addition, as shown in Figure 2.2.2, the sample software is started from the CMSIS startup program 

(startup_S1C31xxx.s), and the system initialization process is executed at startup. 

 

 

Figure 2.2.2 Sample software startup sequence 

  

startup_S1C31xxx.s 

 

system_S1C31xxx.c 

 

board.c 

 

System initialization process 

・ Operating frequency setting 

・ Evaluation board setting 

・ Sys Tick setting 

etc 

BoardInit() 

 

SystemInit() 

 

MCU Hardware 

Drivers¥CMSIS 

(startup_S1C31xxx.s, system_S1C31xxx.c, S1C31xxx.h, etc…) 

 

Drivers¥board 

(board.c, settings.h, etc…) 

Drivers¥sePeripheralLibrary 

(se_clg.c/.h, se_i2c.c/.h, se_pport.c/.h, etc…) 

Middlewares 

(seFlashLibrary etc…) 

Projects 

 (Examples, Applications, etc…) 
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2.3 Evaluation board settings 

The settings.h file contained in the “Drivers ¥ board” folder defines the function settings of the evaluation board. 

Table 2.3.1 shows the setting constants and settings in the settings.h file. These setting constants are commented 

out and undefined by default. If necessary, uncomment it. 

 

Table 2.3.1 S1C31 Family Evaluation Board Definition  

Configuration Feature Defined Un-defined 

UART_PRINTF The standard library printf function 

outputs to the UART console. 

Additional hardware is required. 

For Keil IDE, this configuration 

feature should be defined. 

The semihosting library printf function 

outputs to the IAR IDE terminal 

window. 

EXECUTE_ON_OSC3 The CPU switches to the clock that 

optionally can be run from crystal 

or internal trimmable oscillator in 

the BoardInit function. 

The CPU uses the default clock. 

OSC3_AUTOTRIMMING_ON 

IOSC_AUTOTRIMMING_ON 

OSC3 or IOSC trimming is 

performed in the BoardInit() 

function to achieve higher CPU 

clock accuracy. 

OSC3 or IOSC trimming is not 

performed. This results in a shorter 

boot time. 

OSC3_SRC_XTAL Crystal is source of OSC3 Internal RC oscillator is source of 

OSC3 

CACHE_ENABLED The cache is enabled for the Flash 

targets. No importance for Debug 

targets, 

The cache is not enabled for the 

Flash targets. 

TICKLESS_ENABLED SYSTICK interrupt is disabled. SYSTICK interrupt is used to keep 

track of the elapsed CPU time since 

the last boot. 

BOOT_LOADER Executing code is a boot loader. Executing code is an application. 

QSPI_MODE_SINGLE QSPI SINGLE mode is selected. QSPI DUAL or QUAD modes are 

selected. 

SPIA_DMA Use DMA for SPIA_MASTER and 

SPIA_SLAVE projects. 

Do not use DMA for SPIA_MASTER 

and SPIA_SLAVE projects. 

 

Notes: 

• The definition of “Configuration Feature” is different for each model.  

• To use the UART console for input/output, un-comment UART_PRINTF in the settings.h file. 

• In cases where the CPU deep sleep function is used, un-comment TICKLESS_ENABLED in the settings.h 

file. 
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3 Peripheral circuit sample software execution 

This section describes how to execute the peripheral circuit sample software. 

 

3.1 Advance preparation 

3.1.1 Software download 

Follow the steps below to download and install the software. 

(1) Download the integrated development environment 

Download the integrated development environment (IAR EWARM or MDK-ARM (µVision)). 

After downloading, follow the installer to install. 

 

(2) Download the S1C31 setup tool package 

Download the S1C31 setup tool package (.exe) from Seiko Epson microcontroller website. 

Please download from the following. 

Seiko Epson microcontroller website > EPSON Web Sites > Semiconductors > 

Microcontrollers > Arm® > Software Development Tool 

After downloading, follow the installer to install the flash loader and configuration file 

suitable for your integrated development environment. 

 

(3) Download the S1C31xxx peripheral circuit sample software package 

Download the S1C31xxx Peripheral circuit sample software package (.zip) from Seiko 

Epson microcontroller website. Please download from the following. 

Seiko Epson microcontroller website > EPSON Web Sites > Semiconductors > 

Microcontrollers > Arm® > Application Note / Sample Program 
 

3.1.2 Hardware Connections 

Use the following to execute and debug the peripheral circuit sample software. 

• S5U1C31xxxTx evaluation board 

• Debug probes (IAR Systems I-jet or SEGGER J-Link) 

About details of the hardware connection, refer to the “S5U1C31xxxTx Manual”. 

 

3.1.3 Connection with USB adapter for UART  

The peripheral circuit sample program that uses UART uses a USB adapter for UART. By connecting the 

evaluation boat to the PC using the USB adapter for UART, UART communication with the PC becomes 

possible. Figure 3.1.3.1 show the connection for an USB Adapter for UART to the evaluation board. About the 

connection with the evaluation board, refer to "S5U1C31xxxTx Manual". 

To perform UART communication, it is necessary to build the sample program with the definition of 

UART_PRINTF in the settings.h file enabled (see Section 2.3). In addition, it is necessary to start the serial 

communication terminal software on the PC and set the serial port. Table 3.1.3.1 shows the serial port setting 

values. 
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Figure 3.1.3.1 USB Adapter for UART Wiring to Evaluation Board 

 

Table 3.1.3.1 Serial Port Settings for Terminal Software 

Parameter Setting Value 

Baud rate 115200 bps 

Data 8 bits 

Stop bits 1 bits 

Parity None 

 

Notes: USB adapter for UART used in Figure 3.1.3.1 is a commercial product, not provided by Seiko Epson. 

Please purchase as necessary. 

  

Evaluation Board 

TXD 
UART/Ch.0/USIN 

RXD 

GND 
UART/Ch.0/USOUT 
GND 

USB to PC 

USB adapter for UART 
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3.2 Execution procedure by IAR EWARM 

3.2.1 Start IAR EWARM 

Start IAR EWARM. About details on the version of IAR EWARM used to evaluate the peripheral circuit sample 

software, refer to “README_j.txt” in the S1C31xxx peripheral circuit sample software package. 

 

3.2.2 Workspace Open 

The S1C31xxx Peripheral Circuit Sample Software Package provides projects for each peripheral circuit function 

as peripheral circuit sample software. It provides a workspace that collects projects for each peripheral circuit 

function. 

To open the workspace, click [File] > [Open Workspace] on the IAR EWARM menu, move to the 

“Projects¥Examples¥WORKSPACE¥IAR” folder and select the “Examples.eww” file. (Figure 3.2.2.1) 

 

 

Figure 3.2.2.1 Workspace Open 
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3.2.3 Active Project Selecting 

To build the project, right-click the project to be built and executed in [Workspace] window on IAR EWARM and 

select the [Set as Active] in right-clicked menu. By using the drop-down list at the top of the [Workspace] 

window, the active project and build configuration can be selected at the same time (Figure 3.2.3.1). 

 

 

Figure 3.2.3.1 Active Project Setting 
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3.2.4 Debug Probe Setting 

When connecting a debug probe to the evaluation board for debugging, it is necessary to set the driver according 

to the type of debug probe used. 

To select the debug probe driver, follow the procedure below. (Figure 3.2.4.1) 

(1)  Select the [Project] > [Option] in the IAR EWARM menu. 

(2)  Select the [Debugger] in the [Category] list on the [Options for node “{project}”] dialog. 

(3)  Select the [Setting] tab, and then select the debug probe in the [Driver] drop-down list as shown below. 

- When using the I-jet , select the “I-jet/JTAGjet”. 

- When using the J-Link, select the “J-Link/J-Trace”. 

 

 

Figure 3.2.4.1 Debug Probe Setting 
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3.2.5 Flash Loader Setting 

Set up a flash loader to download the internal Flash memory for active projects. To set the flash loader, follow the 

procedure below. (Figure 3.2.5.1). 

(1)  Select the [Project] > [Option] in the IAR EWARM menu. 

(2)  Select the [Debugger] in the [Category] list on the [Options for node “{project}”] dialog. 

(3)  Select the [Download] tab. 

(4)  Enable the [Use flash loader(s)] checkbox. 

(5)  Enable the [Override default .board file] checkbox. 

(6)  Click the [...] button and select “S1C31xxx_int.board” as a board file. 

 

 

Figure 3.2.5.1 Flash Loader Setting  
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3.2.6 Project Build 

To build an active project, select one of the build commands [Make] or [Rebuild All] from the [Project] in the 

IAR EWARM menu (Figure 3.2.6.1). 

Also, the batch build option to build the projects of all peripheral circuit function at once is available. To use the 

batch build option, select the [Project] > [Batch build…] > “all_DebugFlash” in the IAR EWARM menu.  

 

 

Figure 3.2.6.1 Build Commands 

  

Build the project 

Build the projects of 

all peripheral circuit 

function at once is 

available. 
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3.2.7 Project Download and Debug 

Following a successful build, download the program image of the active project to MCU on the evaluation board. 

To download the program image, select the [Project] > [Download and Debug] in IAR EWARM menu (Figure 

3.2.7.1).  

The project image is loaded in the internal flash memory and debugging is started. 

  

 

Figure 3.2.7.1 Download and Debug 
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3.3 Execution procedure by KEIL MDK-ARM (µVision)  

3.3.1 Start MDK-ARM (µVision) 

Start MDK-ARM (µVision). About details on the version of MDK-ARM used to evaluate the peripheral circuit 

sample software, refer to “README_j.txt” in the S1C31xxx peripheral circuit sample software package. 

 

3.3.2 Workspace Open 

The S1C31xxx Peripheral Circuit Sample Software Package provides projects for each peripheral circuit function 

as peripheral circuit sample software. It provides a workspace that collects projects for each peripheral circuit 

function. 

To open the workspace, click [Project] > [Open Project…] on the uVision menu, move to the 

“Projects¥Examples¥WORKSPACE¥ARM” folder and select the “Examples.uvmpw” file. (Figure 3.3.2.1) 

 

 

Figure 3.3.2.1 Workspace Open 
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3.3.3 Active Project Selecting 

To build the project, select a project to be built and executed. Right-click the target project in [Project] window 

on µVision and select the [Set as Active Project] in right-clicked menu . Next, select the build configuration listed 

in the drop-down list on the tool bar of µVision (Figure 3.3.3.1). 

 

 

Figure 3.3.3.1 Active Project Setting 
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3.3.4 Debug Probe Setting 

When connecting a debug probe to the evaluation board for debugging, it is necessary to set the driver according 

to the type of debug probe used. 

To select the debug probe driver, follow the procedure below. (Figure 3.3.4.1) 

(1)  Select the [Project] > [Options for {project} - Target ‘DebugFlash’’] in the µVision menu. 

(2)  Switch the [Debug] tab in the [Options for Target ‘DebugFlash’’] dialog. 

(3)  Select the “J-Link/J-TRACE Cortex” from the drop-down list at the right side of [Use:] checkbox. 

(4)  Click the [Settings] button at the right side of the above drop-down list. 

(5)  Select the [SW] from the [Port:] drop-down list in the [Cortex JLink/JTrace Target Driver Setup] dialog 

box. 

(6)  Click the all [OK] button to close all dialogs. 

 

Notes:  

• This setting needs to be done with J-Link connected to the PC. 

• J-Link settings are applied to each peripheral circuit function project. 

 

 

Figure 3.3.4.1 Debug Probe Selecting  
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3.3.5 Flash Loader Setting 

Set up a flash loader to download the internal Flash memory for active projects. To set the flash loader, follow the 

procedure below. (Figure 3.3.5.1) 

(1) Select the [Project] > [Options for {project name} - Target ‘DebugFlash’’] in the µVision menu. 

(2) Select the [Utilities] tab in the [Options for Target ‘DebugFlash’] dialog, and click the [Settings] button in 

the [Configure Flash Menu Command]. 

(3) Click the [Add] button in the [Cortex JLink / JTrace Target Driver Setup] dialog and select the flash loader 

“S1C31xxxint yyykB Flash” that matches the target MCU from [Add Flash Programming Algorithm]. 

If a flash loader other than the above is registered in [Programming Algorithm], click the [Remove] button  

to remove it. 

(4) Enable the checkboxes, [Erase Sectors], [Program] and [Verify], in the [Download Function]. 

 

 

Figure 3.3.5.1 Flash Loader Setting 
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3.3.6 Project Build 

To build an active project, select one of the build commands [Build] and [Rebuild] from the [Project] in the 

µVision menu (Figure 3.3.6.1). 

Also, the batch build option to build the projects of all peripheral circuit function at once is available. To use the 

batch build option, select the [Project] > [Batch Build] in theµVision menu.  

 

 

Figure 3.3.6.1 Build Commands 
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3.3.7 Project Download and Debug 

Following a successful build, download the program image of the active project to MCU on the evaluation board. 

To download the program image, select the [Flash] > [Download] in µVision menu (Figure 3.3.7.1).  

To start debugging, select the [Debug] > [Start/Stop Debug Session] in µVision menu (Figure 3.3.7.2). 

 

 

Figure 3.3.7.1 Download 

 

 

Figure 3.3.7.2 Debug 
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4 Peripheral circuit sample software 

Each peripheral circuit sample software shows how to use the peripheral circuit functions. About an overview of 

each peripheral circuit sample software, refer to main.c included in the target project. About the target peripheral 

circuits, refer to "S1C31xxx Technical Manual". 

Table 4.1 shows a list of code sizes when the peripheral circuit sample software is built with IAR EWARM or 

MDK-ARM. 

 

Table 4.1 Code size of each peripheral circuit sample software 

Example Project Name IAR EWARM 

(Code size is 16 KB or less.) 

MDK-ARM 

(Code size is 32 KB or less.) 

ADC12A         

CLG         

DMAC         

I2CLCD32BI2C         

LCD32B         

MCD_LPM012M134B - - 

MDC_LPM012M134B_SERFLASH - - 

MDC_LS012B7DH02 - - 

PPORT         

QSPI         

QSPI_DMA         

QSPI_MASTER         

QSPI_SLAVE         

REMCn         

RFC         

RTCA         

SNDA         

SPI_MASTER         

SPI_SLAVE         

SVDn         

T16         

T16B         

TSRVR - - 

UARTn         

USB_CDC         

USB_HID - - 

USB_MSC - - 

WDT2         

 

Note: Depending on the version of the IDE (Integrated development environment) or the build configuration of 

the IDE, the code size may exceed the size. 
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